Quantcast

nbm from tutorial can not be installed

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

nbm from tutorial can not be installed

screename
Hi,

I followed the tutorial "Quick Start Guide for NetBeans Plug-in Modules". The
plugin works. Than I right-clicked the project and choose "Create NBM". No
errors.
The version of netbeans 4.2 development version.

Then I opened regular netbeans 4.1, click on tools > Update center to install
nbm. I got an error window. The error window asked if I still want to go ahead,
I answered Yes. I got another error and failed.

Now, I want to reproduce the problem, so I can get the error text to ask for
help,
But, I can not get that error, I can not install that nmb: the "Next" and
"Finish"
buttons on the "Select modules to install" remains disabled.

What was worng? How to fix it?
Any information would be appreciated. Thanks in advance.


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: nbm from tutorial can not be installed

screename
I can reproduce the error message now:

The following modele dependencies could not be satisfied:
MODULE: com.acele.netbeans.redressmodule org.openide.execution.deprecated
>1.0module
org.openide.filesystems > 6.2token org.openide.compile.ComilationEnginemodule
org.openide.compile
> 1.0toke org.openide.modules.ModuleFormat1token org.openide.TopManagermodule
org.openide.deprecated > 1.0module org.openide.util > 6.2
Module can be downloaded, but connot be enable.
Include modele in install list anyway?

What was wrong? How to fix it?


I restart both dev and regular netbeas, no use. I rebooted my machine, no use.
Then, I manually removed a copy of the nbm from my home directory. I can get
the error message.....

--- Wei Jiang <[hidden email]> wrote:

> Hi,
>
> I followed the tutorial "Quick Start Guide for NetBeans Plug-in Modules". The
> plugin works. Than I right-clicked the project and choose "Create NBM". No
> errors.
> The version of netbeans 4.2 development version.
>
> Then I opened regular netbeans 4.1, click on tools > Update center to install
> nbm. I got an error window. The error window asked if I still want to go
> ahead,
> I answered Yes. I got another error and failed.
>
> Now, I want to reproduce the problem, so I can get the error text to ask for
> help,
> But, I can not get that error, I can not install that nmb: the "Next" and
> "Finish"
> buttons on the "Select modules to install" remains disabled.
>
> What was worng? How to fix it?
> Any information would be appreciated. Thanks in advance.
>
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com 
>


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: nbm from tutorial can not be installed

Jesse Glick
In reply to this post by screename
Wei Jiang wrote:
> I followed the tutorial "Quick Start Guide for NetBeans Plug-in
> Modules". The plugin works. Than I right-clicked the project and
> choose "Create NBM". No errors. The version of netbeans 4.2
> development version.
>
> Then I opened regular netbeans 4.1, click on tools > Update center to
> install nbm. I got an error window. [...]

You cannot use the 4.2 module development support to build modules for
4.1 (unless you manually clean up a few things in the module manifest).

-J.

--
[hidden email]   x22801   netbeans.org   ant.apache.org

Loading...