Whats up with the design?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Whats up with the design?

MEngberg
Hi

I recently started using Netbeans. I have a problem with the design. In the building phase, my design looks good. Then when I run the program it looks so different. Why is this? I've uploaded pictures.




Attachments:
http://forums.netbeans.org//files/braversion_317.png
http://forums.netbeans.org//files/dlig_174.png

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Whats up with the design?

wadechandler
Administrator
Some of the edges anchors are probably not set on the text boxes; why they are shifted. The biggest issue is the look and feel used most likely.

Wade


On Dec 26, 2016 9:54 AM, "MEngberg" <[hidden email]> wrote:
Hi

I recently started using Netbeans. I have a problem with the design. In the building phase, my design looks good. Then when I run the program it looks so different. Why is this? I've uploaded pictures.




Attachments:
http://forums.netbeans.org//files/braversion_317.png
http://forums.netbeans.org//files/dlig_174.png


====================
Wade Chandler

Software Engineer
NetBeans and Open Source Contributor
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Whats up with the design?

Chuck Davis-3
If it were mine I would select all the boxes and use alignment feature.  You can align all to left, center or right with the alignment icons.

On Mon, Dec 26, 2016 at 8:32 PM, Wade Chandler <[hidden email]> wrote:
Some of the edges anchors are probably not set on the text boxes; why they are shifted. The biggest issue is the look and feel used most likely.

Wade


On Dec 26, 2016 9:54 AM, "MEngberg" <[hidden email]> wrote:
Hi

I recently started using Netbeans. I have a problem with the design. In the building phase, my design looks good. Then when I run the program it looks so different. Why is this? I've uploaded pictures.




Attachments:
http://forums.netbeans.org//files/braversion_317.png
http://forums.netbeans.org//files/dlig_174.png


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Whats up with the design?

Stanislav Baiduzhyi
In reply to this post by MEngberg
Design preview is shown using your current NetBeans LookAndFeel, while the application gets the default. Try setting the LookAndFeel manually as first thing you do in EDT when your application initializes.

On Mon, Dec 26, 2016 at 3:44 PM MEngberg <[hidden email]> wrote:
Hi

I recently started using Netbeans. I have a problem with the design. In the building phase, my design looks good. Then when I run the program it looks so different. Why is this? I've uploaded pictures.




Attachments:
http://forums.netbeans.org//files/braversion_317.png
http://forums.netbeans.org//files/dlig_174.png

Loading...