VisualWebJSF Portlet can't work in Liferay+Tomcat?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

VisualWebJSF Portlet can't work in Liferay+Tomcat?

yi.wang.info
This post was updated on .
I create my Visual Web JSF Portlet Page in NetBeans6.5.1 ( with PortalPack3.0 ), but it work not very well...
In the first time, there is nothing, the page is blocked, I get
http://localhost:8080/WebApplication1/theme/com/sun/webui/jsf/suntheme4_2-080320/javascri/bootstrap.js
 405 - Method not allowed
webui is not defined http://localhost:8080/web/guest Line 0
 
with Firebug 1.3.3,
after that, I need reload the page for display my portlet...
Thanks for the answer!
Reply | Threaded
Open this post in threaded view
|

Re: VisualWebJSF Portlet can't work in Liferay+Tomcat?

yi.wang.info
It's ok, the error is resolved!
In liferay-portlet.xml: del <instanceable>true</instanceable>, add <ajaxable>false</ajaxable> in <portlet>.

But I have still the problem de reload!
It's mean: I can't see my portlet until reload the page...
( NetBeans6.5.1 + PortalPack3.0 + Liferay5.22 + Tomcat6.018 )
Sorry for my english, thank you for your answer.
:)


yi.wang.info wrote
I create my Visual Web JSF Portlet Page in NetBeans6.5.1 ( with PortalPack3.0 ), but it work not very well...
In the first time, there is nothing, the page is blocked, I get
http://localhost:8080/WebApplication1/theme/com/sun/webui/jsf/suntheme4_2-080320/javascri/bootstrap.js
 405 - Method not allowed
webui is not defined http://localhost:8080/web/guest Line 0
 
with Firebug 1.3.3,
after that, I need reload the page for display my portlet...
Thanks for the answer!