Problems with the JBoss plugin on Netbeans 4.1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with the JBoss plugin on Netbeans 4.1

Daniel Bos
I installed nb 4.1 and downloaded all the updates. I also installed
JBoss 4.02 and i want to start from nb the jboss.

then i get a error:

Annotation: Exception occurred in Request Processor
javax.xml.parsers.FactoryConfi­gurationError: Provider
org.apache.crimson.jaxp.Docume­ntBuilderFactoryImpl not found
       at
javax.xml.parsers.DocumentBuil­derFactory.newInstance(Documen­tBuilderFactory.java:99)
       at
org.netbeans.modules.j2ee.jbos­s4.ide.ui.JBPluginUtils.getJnp­Port(JBPluginUtils.java:152)
       at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isReallyR­unning(JBStartServer.java:137)
       at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isRunning­(JBStartServer.java:177)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unningWithinMillis(ServerInsta­nce.java:336)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unning(ServerInstance.java:329­)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.setCommandControlButtons(Serv­erStatusBar.java:265)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.startProgressUI(ServerStatusB­ar.java:98)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.actions.ServerS­tatusAction$1.run(ServerStatus­Action.java:58)
       at org.openide.util.Task.run(Task­.java:189)
       at
org.openide.util.RequestProces­sor$Task.run(RequestProcessor.­java:330)
[catch] at
org.openide.util.RequestProces­sor$Processor.run(RequestProce­ssor.java:721)
==>
java.lang.ClassNotFoundExcepti­on:
org.apache.crimson.jaxp.Docume­ntBuilderFactoryImpl
       at java.net.URLClassLoader$1.run(­URLClassLoader.java:199)
       at java.security.AccessController­.doPrivileged(Native Method)
       at java.net.URLClassLoader.findCl­ass(URLClassLoader.java:187)
       at java.lang.ClassLoader.loadClas­s(ClassLoader.java:289)
       at java.lang.ClassLoader.loadClas­s(ClassLoader.java:235)
       at javax.xml.parsers.FactoryFinde­r.newInstance(FactoryFinder.ja­va:93)
       at javax.xml.parsers.FactoryFinde­r.find(FactoryFinder.java:187)
       at
javax.xml.parsers.DocumentBuil­derFactory.newInstance(Documen­tBuilderFactory.java:93)
       at
org.netbeans.modules.j2ee.jbos­s4.ide.ui.JBPluginUtils.getJnp­Port(JBPluginUtils.java:152)
       at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isReallyR­unning(JBStartServer.java:137)
       at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isRunning­(JBStartServer.java:177)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unningWithinMillis(ServerInsta­nce.java:336)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unning(ServerInstance.java:329­)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.setCommandControlButtons(Serv­erStatusBar.java:265)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.startProgressUI(ServerStatusB­ar.java:98)
       at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.actions.ServerS­tatusAction$1.run(ServerStatus­Action.java:58)
       at org.openide.util.Task.run(Task­.java:189)
       at
org.openide.util.RequestProces­sor$Task.run(RequestProcessor.­java:330)
[catch] at
org.openide.util.RequestProces­sor$Processor.run(RequestProce­ssor.java:721)


What i do wrong..

Thanks in advance,

Daniel
Reply | Threaded
Open this post in threaded view
|

Problems with the JBoss plugin on Netbeans 4.1

Daniel Bos
I installed nb 4.1 and downloaded all the updates. I also installed
JBoss 4.02 and i want to start from nb the jboss.

then i get a error:

Annotation: Exception occurred in Request Processor
javax.xml.parsers.FactoryConfi­gurationError: Provider
org.apache.crimson.jaxp.Docume­ntBuilderFactoryImpl not found
      at
javax.xml.parsers.DocumentBuil­derFactory.newInstance(Documen­tBuilderFactory.java:99)
      at
org.netbeans.modules.j2ee.jbos­s4.ide.ui.JBPluginUtils.getJnp­Port(JBPluginUtils.java:152)
      at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isReallyR­unning(JBStartServer.java:137)
      at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isRunning­(JBStartServer.java:177)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unningWithinMillis(ServerInsta­nce.java:336)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unning(ServerInstance.java:329­)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.setCommandControlButtons(Serv­erStatusBar.java:265)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.startProgressUI(ServerStatusB­ar.java:98)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.actions.ServerS­tatusAction$1.run(ServerStatus­Action.java:58)
      at org.openide.util.Task.run(Task­.java:189)
      at
org.openide.util.RequestProces­sor$Task.run(RequestProcessor.­java:330)
[catch] at
org.openide.util.RequestProces­sor$Processor.run(RequestProce­ssor.java:721)
==>
java.lang.ClassNotFoundExcepti­on:
org.apache.crimson.jaxp.Docume­ntBuilderFactoryImpl
      at java.net.URLClassLoader$1.run(­URLClassLoader.java:199)
      at java.security.AccessController­.doPrivileged(Native Method)
      at java.net.URLClassLoader.findCl­ass(URLClassLoader.java:187)
      at java.lang.ClassLoader.loadClas­s(ClassLoader.java:289)
      at java.lang.ClassLoader.loadClas­s(ClassLoader.java:235)
      at javax.xml.parsers.FactoryFinde­r.newInstance(FactoryFinder.ja­va:93)
      at javax.xml.parsers.FactoryFinde­r.find(FactoryFinder.java:187)
      at
javax.xml.parsers.DocumentBuil­derFactory.newInstance(Documen­tBuilderFactory.java:93)
      at
org.netbeans.modules.j2ee.jbos­s4.ide.ui.JBPluginUtils.getJnp­Port(JBPluginUtils.java:152)
      at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isReallyR­unning(JBStartServer.java:137)
      at
org.netbeans.modules.j2ee.jbos­s4.ide.JBStartServer.isRunning­(JBStartServer.java:177)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unningWithinMillis(ServerInsta­nce.java:336)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ServerInstance.isR­unning(ServerInstance.java:329­)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.setCommandControlButtons(Serv­erStatusBar.java:265)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.ServerStatusBar­.startProgressUI(ServerStatusB­ar.java:98)
      at
org.netbeans.modules.j2ee.depl­oyment.impl.ui.actions.ServerS­tatusAction$1.run(ServerStatus­Action.java:58)
      at org.openide.util.Task.run(Task­.java:189)
      at
org.openide.util.RequestProces­sor$Task.run(RequestProcessor.­java:330)
[catch] at
org.openide.util.RequestProces­sor$Processor.run(RequestProce­ssor.java:721)


What i do wrong..

Thanks in advance,

Daniel
Reply | Threaded
Open this post in threaded view
|

Re: Problems with the JBoss plugin on Netbeans 4.1

Petr Blaha
In reply to this post by Daniel Bos
Hi Daniel,
can you file a new issue in component/subcomponent serverplugins/jboss4.
Please, add steps to reproduce and your configuration (jdk version, OS )
as well

Thanks,
Petr

Daniel Bos wrote:

> I installed nb 4.1 and downloaded all the updates. I also installed
> JBoss 4.02 and i want to start from nb the jboss.
>
> then i get a error:
>
> Annotation: Exception occurred in Request Processor
> javax.xml.parsers.FactoryConfi?gurationError: Provider
> org.apache.crimson.jaxp.Docume?ntBuilderFactoryImpl not found
>        at
> javax.xml.parsers.DocumentBuil?derFactory.newInstance(Documen?tBuilderFactory.java:99)
>        at
> org.netbeans.modules.j2ee.jbos?s4.ide.ui.JBPluginUtils.getJnp?Port(JBPluginUtils.java:152)
>        at
> org.netbeans.modules.j2ee.jbos?s4.ide.JBStartServer.isReallyR?unning(JBStartServer.java:137)
>        at
> org.netbeans.modules.j2ee.jbos?s4.ide.JBStartServer.isRunning?(JBStartServer.java:177)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ServerInstance.isR?unningWithinMillis(ServerInsta?nce.java:336)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ServerInstance.isR?unning(ServerInstance.java:329?)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ui.ServerStatusBar?.setCommandControlButtons(Serv?erStatusBar.java:265)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ui.ServerStatusBar?.startProgressUI(ServerStatusB?ar.java:98)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ui.actions.ServerS?tatusAction$1.run(ServerStatus?Action.java:58)
>        at org.openide.util.Task.run(Task?.java:189)
>        at
> org.openide.util.RequestProces?sor$Task.run(RequestProcessor.?java:330)
> [catch] at
> org.openide.util.RequestProces?sor$Processor.run(RequestProce?ssor.java:721)
> ==>
> java.lang.ClassNotFoundExcepti?on:
> org.apache.crimson.jaxp.Docume?ntBuilderFactoryImpl
>        at java.net.URLClassLoader$1.run(?URLClassLoader.java:199)
>        at java.security.AccessController?.doPrivileged(Native Method)
>        at java.net.URLClassLoader.findCl?ass(URLClassLoader.java:187)
>        at java.lang.ClassLoader.loadClas?s(ClassLoader.java:289)
>        at java.lang.ClassLoader.loadClas?s(ClassLoader.java:235)
>        at javax.xml.parsers.FactoryFinde?r.newInstance(FactoryFinder.ja?va:93)
>        at javax.xml.parsers.FactoryFinde?r.find(FactoryFinder.java:187)
>        at
> javax.xml.parsers.DocumentBuil?derFactory.newInstance(Documen?tBuilderFactory.java:93)
>        at
> org.netbeans.modules.j2ee.jbos?s4.ide.ui.JBPluginUtils.getJnp?Port(JBPluginUtils.java:152)
>        at
> org.netbeans.modules.j2ee.jbos?s4.ide.JBStartServer.isReallyR?unning(JBStartServer.java:137)
>        at
> org.netbeans.modules.j2ee.jbos?s4.ide.JBStartServer.isRunning?(JBStartServer.java:177)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ServerInstance.isR?unningWithinMillis(ServerInsta?nce.java:336)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ServerInstance.isR?unning(ServerInstance.java:329?)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ui.ServerStatusBar?.setCommandControlButtons(Serv?erStatusBar.java:265)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ui.ServerStatusBar?.startProgressUI(ServerStatusB?ar.java:98)
>        at
> org.netbeans.modules.j2ee.depl?oyment.impl.ui.actions.ServerS?tatusAction$1.run(ServerStatus?Action.java:58)
>        at org.openide.util.Task.run(Task?.java:189)
>        at
> org.openide.util.RequestProces?sor$Task.run(RequestProcessor.?java:330)
> [catch] at
> org.openide.util.RequestProces?sor$Processor.run(RequestProce?ssor.java:721)
>
>
> What i do wrong..
>
> Thanks in advance,
>
> Daniel