Probably wrong information

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Probably wrong information

Peter Cheung

Hi All in http://wiki.netbeans.org/DevFaqImplementationDependency



This line "OpenIDE-Module-Module-Dependencies: some.other.module > 1.5" should be in src/main/nbm/manifest.mf, rather than nbproject/project.xml


Am I correct?

thanks

from Peter

Reply | Threaded
Open this post in threaded view
|

Re: Probably wrong information

Benno Markiewicz
No. 

nbproject/project.xml is for Ant-based projects and 
 src/main/nbm/manifest.mf is  for Maven-based projects. 

But yes the documentation could be more detailed about this

Best regards 

Den 28 jan. 2017 08:24 skrev "Peter Cheung" <[hidden email]>:

Hi All in http://wiki.netbeans.org/DevFaqImplementationDependency



This line "OpenIDE-Module-Module-Dependencies: some.other.module > 1.5" should be in src/main/nbm/manifest.mf, rather than nbproject/project.xml


Am I correct?

thanks

from Peter


Reply | Threaded
Open this post in threaded view
|

Re: Probably wrong information

Peter Cheung

Thanks




From: Benno Markiewicz <[hidden email]>
Sent: Sunday, January 29, 2017 2:31 AM
To: dev
Subject: [platform-dev] Re: Probably wrong information
 
No. 

nbproject/project.xml is for Ant-based projects and 
 src/main/nbm/manifest.mf is  for Maven-based projects. 

But yes the documentation could be more detailed about this

Best regards 

Den 28 jan. 2017 08:24 skrev "Peter Cheung" <[hidden email]>:

Hi All in http://wiki.netbeans.org/DevFaqImplementationDependency



This line "OpenIDE-Module-Module-Dependencies: some.other.module > 1.5" should be in src/main/nbm/manifest.mf, rather than nbproject/project.xml


Am I correct?

thanks

from Peter