Netbeans 8.1 and Maven problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Netbeans 8.1 and Maven problem

Reg65
Hello,

I'm new to Java and Maven but I have been using Netbeans with PHP for quite some time.

I have a need to load a Maven project into Netbeans however I can't make it work. At first I thought it had something to do with loading the source of this project (drools) however just as a test I tried to create a new Maven Java project and that too would not show as a project in NB. I could however make it show up on favorites, but not the Projects tab.

I don't know if this is normal so perhaps it is and there is nothing wrong but with no experience in Java and its related technologies I simply don't know. I do know that when a Maven project is created that no nbproject folder is created which leaves me to suspect that maybe that's just the way it is.

I did enable a number of plugins related to Maven and Java, perhaps I just enabled something that has a bug, if that's possible, is there a minimum list of plugins to enable for Maven and Java working together?

Could someone please let me know if I have a problem or if this is normal behavior and give any possible remedies?

Any help appreciated!

Reg




Reply | Threaded
Open this post in threaded view
|

Netbeans 8.1 and Maven problem

tkellerer

Reg65 wrote:
> I have a need to load a Maven project into Netbeans however I can't make it work. At first I thought it had something to do with loading the source of this project (drools) however just as a test I tried to create a new Maven Java project and that too would not show as a project in NB. I could however make it show up on favorites, but not the Projects tab.
How did you open that project. For Maven projects all you need to do is "File -> Open Project" and then select the directory where pom.xml is located. Those directories will show up with a little Maven icon next to them in the file open dialog

As a side note: why are you using 8.1? 8.2 is the current version.




Attachments:
http://forums.netbeans.org//files/open_137.png

Reply | Threaded
Open this post in threaded view
|

Netbeans 8.1 and Maven problem

Reg65
In reply to this post by Reg65

> Maven projects all you need to do is "File -> Open Project" and then select the directory where pom.xml is located

That's what I did many times and I tried many other things. Like I said, I tried to create a new Maven project and that did not show up in the project tab either.

On my OS NB 8.1 is what is current, I'm sure it will update to 8.2 soon enough. I run Tumbleweed/Linux. I could probably download the latest NB but I prefer to wait until it updates itself unless there's a requirement to update sooner.




Reply | Threaded
Open this post in threaded view
|

Netbeans 8.1 and Maven problem

tkellerer
In reply to this post by Reg65

Reg65 wrote:
> That's what I did many times and I tried many other things. Like I said, I tried to create a new Maven project and that did not show up in the project tab either.


Without more details this is extremely hard to answer. Does the Maven project show up with the little Maven icon in the file open dialog? Do you see any errors in the NetBeans log file? (View -> IDE Log). If yes, what are those errors?

As you started out with the PHP Version of NetBeans: are the Java modules all installed and enabled? If those Maven projects are Web Applications you also need the Java EE modules.




Attachments:
http://forums.netbeans.org//files/modules_186.png

Reply | Threaded
Open this post in threaded view
|

Netbeans 8.1 and Maven problem

Reg65
In reply to this post by Reg65
I had all of those except hibernate which I have since added. However, because this is all new to me I might have added something that I should not have as well. I've attached my add-ons, if you see anything that could be a problem please let me know.




Attachments:
http://forums.netbeans.org//files/addons_585.png

Reply | Threaded
Open this post in threaded view
|

Netbeans 8.1 and Maven problem

Reg65
In reply to this post by Reg65
So I deleted my NB installation, removed all the settings, removed it's cache, installed 8.2 and it works as it should now.

I think that was a much faster solution than trying to determine the cause especially since I don't know Java and Maven yet.