Intro & question

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Intro & question

Ben Fourie

Hi everyone


I’m new to this list and thought i will introduce myself first.
I’m a java backend dev during the day for the leading healthcare insurance company in South Africa. Discovery.
I’m also a hobbyist and program my raspberry pies with netbeans.

And in that, I ran into a problem.
The reason I chose Netbeans as the ide for my hobby side, is because it natively supports remote debugging. It worked very well.
I setup a remote platform, and it tested okey.

Ran a few spike programs, all worked great. So I click run on my mac, and the code runs on the pi. Perfect.

But that stopped working. :(

I uninstalled netbeans, and reinstalled 8.2 from a fresh download.
Problem persists. In project properties, under the run tab, I no longer have a dropdown for remote platform. Remote platform is configured and tested ok. I gave the raspberry pi a static ip.

I followed these instructions which worked before:

In there, the run tab looks something like this:

image1.jpeg

As you can see, it’s easy to just select another platform. Ie the one configured for the remote raspberry pi.

However, my screen looks like this now.

image2.jpeg

I no longer have the option to select the remote, or any other platform.

Has anyone experienced something like this?

Kind regards
Ben Fourie