Error: No enterprise bean matching [ Converter Bean ] found within [null] EAR file. Help.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Error: No enterprise bean matching [ Converter Bean ] found within [null] EAR file. Help.

Philip Gladwin

Good afternoon,

I am working my way through Chapter 5 (“Getting started with Enterprise Beans”) from

‘The J2EE 1.4 Tutorial for Netbeans IDE 4.1’ and find it very well written.

 

However, I am attempting to deploy the ‘ConverterApp’ and run into problems.  I have repeated the exercise three time and continue to receive the same error.  I find that my ConverterApp-EJBModule verifies correctly, but when I verify my ConverterApp-WebModule I receive the following error:

 

Fail: The value of the ejb-link element is the ejb-name of an enterprise bean in the same J2EE application achive.

 

In the Detail pane I see

Error: No enterprise bean matching [ ConverterBean ] found within [null] EAR file.

 

Can anybody help me?

 

Kind regards,

Philip Gladwin

 

Reply | Threaded
Open this post in threaded view
|

Re: Error: No enterprise bean matching [ Converter Bean ] found within [null] EAR file. Help.

Christopher Webster
It sounds like there is no J2EE application project, or if there is this
is not what is being deployed / verified. Make sure that a J2EE
application project has been created (and the web and ejb modules
added), also that the J2EE application verifies correctly.

Chris

Philip Gladwin wrote:

> Good afternoon,
>
> I am working my way through Chapter 5 (?Getting started with Enterprise
> Beans?) from
>
> ?The J2EE 1.4 Tutorial for Netbeans IDE 4.1? and find it very well written.
>
>  
>
> However, I am attempting to deploy the ?ConverterApp? and run into
> problems.  I have repeated the exercise three time and continue to
> receive the same error.  I find that my ConverterApp-EJBModule verifies
> correctly, but when I verify my ConverterApp-WebModule I receive the
> following error:
>
>  
>
> Fail: The value of the ejb-link element is the ejb-name of an enterprise
> bean in the same J2EE application achive.
>
>  
>
> In the Detail pane I see
>
> Error: No enterprise bean matching [ ConverterBean ] found within [null]
> EAR file.
>
>  
>
> Can anybody help me?
>
>  
>
> Kind regards,
>
> Philip Gladwin
>
>  
>


--
          ______
         /_____/\             Christopher B. Webster
        /____ \\ \            Member of Technical Staff
       /_____\ \\ /
      /_____/ \/ / /          Sun Microsystems, Inc.
     /_____/ /   \//\
     \_____\//\   / /
      \_____/ / /\ /
       \_____/ \\ \
        \_____\ \\
         \_____\/