Compiling with JDK 9 EA - weird (incorrect?) message about ant version

Previous Topic Next Topic
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Compiling with JDK 9 EA - weird (incorrect?) message about ant version

Thomas Wolf-7
I am running NB 8.2 (under JDK 8) with all the latest updates and am trying to build my application under the EA version of JDK 9 (build 181).  I got some weird module-related errors (I was using using org.omg.CORBA.StringHolder which, apparently, is in a jar that's not included by default during compiles) but because I initially didn't understand, I decided to switch over to the dev build of Netbeans and run it under JDK 9 EA as well.

Well, I got everything working there (add "--add-modules java.corba" to compile options).  But since the IDE didn't seem terribly reliable under the 9 EA (got exception every time I exited the IDE and exception when trying to save some Options), I decided to go back to NB 8.2.

But in 8.2, now I get the following error when trying to build:

C:\Users\thwolf\Documents\NetBeansProjects\SimulationStudio\nbproject\build-impl.xml:86: Java 9 support requires Ant 1.10.0 or higher.

When I do "ant -version", I see that I'm running 1.10.1 - so that error message seems misleading.  The target that it throws up on is:

    <target depends="-init-modules-supported,-init-macrodef-modulename" if="modules.supported.internal" name="-init-source-module-properties">
        <fail message="Java 9 support requires Ant 1.10.0 or higher.">
                    <antversion atleast="1.10.0"/>

I thought that it might be some cached stuff from the dev build running on the EA or maybe that compiler option - so I cleared the cache ($HOME/AppData/Local/Netbeans/cache) and got rid of that option, but the error stays the same.

Does anyone have any suggestions as to what's going on?  Or am I trying something impossible (compile an app in JDK 9 with the IDE running in JDK 8)?

Thanks for any enlightenment,