Quantcast

Can't Run!! Help!

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Can't Run!! Help!

litmuz
I'm a new developer. This will be my first time programming in Javascript. I've been struggling and struggling to set up an IDE and I'm going CRAZY!! [Shocked]

In the project that I imported (I'm working on a Chrome plugin), the Run button is greyed out.

It works fine in the bunnies example.

I'm having this problem in both my HTML and js files.

I understand that one the issue might be the Compile on Save setting, but I can't find the setting by accessing Properties by right clicking on my project in the menu (see screenshot 1), or in Preferences from the Netbeans dropdown (see screenshot 2.

In a tutorial video I found, the guy got to that setting by right clicking on the white dropdown in the toolbar. But my dropdown is empty and I can't right click it. (see screenshot 3.)

Run is also greyed out when I highlight and right click lines of code.

There aren't any red underlines in my HTML or js files. But I do have yellow triangle ! symbols. (Which is annoying. It doesn't like my favicons, which worked fine in the browser.) (Not sure what it's objecting to in the js.)

If it matters, I'm working on a Mac.

Am I missing something obvious??




Attachments:
http://forums.netbeans.org//files/screen_shot_2017_05_11_at_111953_am_309.png
http://forums.netbeans.org//files/screen_shot_2017_05_11_at_103056_am_195.png
http://forums.netbeans.org//files/screen_shot_2017_05_11_at_111220_am_282.png

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't Run!! Help!

Geertjan Wielenga-3


On 11-5-2017 17:20, litmuz wrote:
> I'm a new developer. This will be my first time programming in Javascript. I've been struggling and struggling to set up an IDE and I'm going CRAZY!! [Shocked]
>
> In the project that I imported (I'm working on a Chrome plugin), the Run button is greyed out.

Probably because you've not selected a project to run.

Gj

>
> It works fine in the bunnies example.
>
> I'm having this problem in both my HTML and js files.
>
> I understand that one the issue might be the Compile on Save setting, but I can't find the setting by accessing Properties by right clicking on my project in the menu (see screenshot 1), or in Preferences from the Netbeans dropdown (see screenshot 2.
>
> In a tutorial video I found, the guy got to that setting by right clicking on the white dropdown in the toolbar. But my dropdown is empty and I can't right click it. (see screenshot 3.)
>
> Run is also greyed out when I highlight and right click lines of code.
>
> There aren't any red underlines in my HTML or js files. But I do have yellow triangle ! symbols. (Which is annoying. It doesn't like my favicons, which worked fine in the browser.) (Not sure what it's objecting to in the js.)
>
> If it matters, I'm working on a Mac.
>
> Am I missing something obvious??
>
>
>
>
> Attachments:
> http://forums.netbeans.org//files/screen_shot_2017_05_11_at_111953_am_309.png
> http://forums.netbeans.org//files/screen_shot_2017_05_11_at_103056_am_195.png
> http://forums.netbeans.org//files/screen_shot_2017_05_11_at_111220_am_282.png
>

Loading...